2026-10-30 18:11CVE-2026-39739Patchstack
PUBLISHED5.2CWE-79x_open-source

WordPress Ultimate Addons for Elementor - Lite plugin <= 2.9.5 - Cross Site Scripting (XSS) vulnerability

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Brainstorm Force Ultimate Addons for Elementor - Lite header-footer-elementor allows Stored XSS.This issue affects Ultimate Addons for Elementor - Lite: from n/a through 2.9.5.

Problem type

Affected products

Brainstorm Force

Ultimate Addons for Elementor - Lite

<= 2.9.5 - AFFECTED

References

JSON source

https://cveawg.mitre.org/api/cve/CVE-2026-39739
Click to expand
{
  "dataType": "CVE_RECORD",
  "dataVersion": "5.2",
  "cveMetadata": {
    "cveId": "CVE-2026-39739",
    "assignerOrgId": "21595511-bba5-4825-b968-b78d1f9984a3",
    "assignerShortName": "Patchstack",
    "dateUpdated": "2026-10-30T18:11:41.641Z",
    "dateReserved": "2026-04-07T10:58:45.543Z",
    "datePublished": "2026-10-30T18:11:41.349Z",
    "state": "PUBLISHED"
  },
  "containers": {
    "cna": {
      "providerMetadata": {
        "orgId": "21595511-bba5-4825-b968-b78d1f9984a3",
        "shortName": "Patchstack",
        "dateUpdated": "2026-10-30T18:11:41.641Z"
      },
      "datePublic": "2026-10-30T18:10:00.000Z",
      "title": "WordPress Ultimate Addons for Elementor - Lite plugin <= 2.9.5 - Cross Site Scripting (XSS) vulnerability",
      "descriptions": [
        {
          "lang": "en",
          "value": "Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Brainstorm Force Ultimate Addons for Elementor - Lite header-footer-elementor allows Stored XSS.This issue affects Ultimate Addons for Elementor - Lite: from n/a through 2.9.5.",
          "supportingMedia": [
            {
              "type": "text/html",
              "base64": false,
              "value": "Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Brainstorm Force Ultimate Addons for Elementor - Lite header-footer-elementor allows Stored XSS.<p>This issue affects Ultimate Addons for Elementor - Lite: from n/a through 2.9.5.</p>"
            }
          ]
        }
      ],
      "affected": [
        {
          "vendor": "Brainstorm Force",
          "product": "Ultimate Addons for Elementor - Lite",
          "collectionURL": "https://wordpress.org/plugins",
          "packageName": "header-footer-elementor",
          "defaultStatus": "unaffected",
          "versions": [
            {
              "version": "0",
              "status": "affected",
              "versionType": "custom",
              "lessThanOrEqual": "2.9.5"
            }
          ]
        }
      ],
      "problemTypes": [
        {
          "descriptions": [
            {
              "lang": "en",
              "description": "Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')",
              "cweId": "CWE-79",
              "type": "CWE"
            }
          ]
        }
      ],
      "references": [
        {
          "url": "https://patchstack.com/database/wordpress/plugin/header-footer-elementor/vulnerability/wordpress-ultimate-addons-for-elementor-lite-plugin-2-9-5-cross-site-scripting-xss-vulnerability?_s_id=cve",
          "tags": [
            "vdb-entry"
          ]
        }
      ],
      "impacts": [
        {
          "capecId": "CAPEC-592",
          "descriptions": [
            {
              "lang": "en",
              "value": "Stored XSS"
            }
          ]
        }
      ],
      "metrics": [
        {
          "format": "CVSS",
          "scenarios": [
            {
              "lang": "en",
              "value": "GENERAL"
            }
          ],
          "cvssV3_1": {
            "version": "3.1",
            "vectorString": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L",
            "attackVector": "NETWORK",
            "attackComplexity": "LOW",
            "privilegesRequired": "LOW",
            "userInteraction": "REQUIRED",
            "scope": "CHANGED",
            "confidentialityImpact": "LOW",
            "integrityImpact": "LOW",
            "availabilityImpact": "LOW",
            "baseScore": 6.5,
            "baseSeverity": "MEDIUM"
          }
        }
      ],
      "solutions": [
        {
          "lang": "en",
          "value": "Update the WordPress Ultimate Addons for Elementor - Lite plugin to the latest available version (at least 2.9.6).",
          "supportingMedia": [
            {
              "type": "text/html",
              "base64": false,
              "value": "Update the WordPress Ultimate Addons for Elementor - Lite plugin to the latest available version (at least 2.9.6)."
            }
          ]
        }
      ],
      "credits": [
        {
          "lang": "en",
          "value": "fccsec.dev | Patchstack Bug Bounty Program",
          "type": "finder"
        }
      ],
      "tags": [
        "x_open-source"
      ]
    }
  }
}